summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix15
1 files changed, 5 insertions, 10 deletions
diff --git a/flake.nix b/flake.nix
index 9d55717..7aaaf67 100644
--- a/flake.nix
+++ b/flake.nix
@@ -103,6 +103,7 @@
lspsAndRuntimeDeps = {
general = with pkgs; {
lua = [ lua-language-server ];
+ nix = [ nix-doc nixd ];
};
};
@@ -210,6 +211,7 @@
aliases = [ "vim" ];
neovim-unwrapped = inputs.neovim-nightly-overlay.packages.${pkgs.system}.neovim;
};
+
# and a set of categories that you want
# (and other information to pass to lua)
categories = {
@@ -219,17 +221,10 @@
general = true;
gitPlugins = true;
customPlugins = true;
+ };
- test = true;
- example = {
- youCan = "add more than just booleans";
- toThisSet = [
- "and the contents of this categories set"
- "will be accessible to your lua with"
- "nixCats('path.to.value')"
- "see :help nixCats"
- ];
- };
+ extra = {
+ nixdExtras = { inherit nixpkgs; };
};
};
};