aboutsummaryrefslogtreecommitdiff
path: root/system-sapphire.nix
diff options
context:
space:
mode:
authorLibravatar Mora Unie Youer <[email protected]>2025-02-27 21:05:52 +0300
committerLibravatar Mora Unie Youer <[email protected]>2025-02-27 21:05:52 +0300
commit87e6c0e3a7618a3f9b97491c87d46f894bc0ced0 (patch)
tree726a7ae3a5f652a659dcce7cbe10d9a0a04210a6 /system-sapphire.nix
parentfeat(sapphire): configure `nix-ld` (diff)
downloadnixos-configuration-87e6c0e3a7618a3f9b97491c87d46f894bc0ced0.tar.gz
nixos-configuration-87e6c0e3a7618a3f9b97491c87d46f894bc0ced0.tar.bz2
nixos-configuration-87e6c0e3a7618a3f9b97491c87d46f894bc0ced0.tar.lz
nixos-configuration-87e6c0e3a7618a3f9b97491c87d46f894bc0ced0.tar.xz
nixos-configuration-87e6c0e3a7618a3f9b97491c87d46f894bc0ced0.tar.zst
nixos-configuration-87e6c0e3a7618a3f9b97491c87d46f894bc0ced0.zip
feat(sapphire): enable XDG portal for graphics environment
Diffstat (limited to '')
-rw-r--r--system-sapphire.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/system-sapphire.nix b/system-sapphire.nix
index 6f9ddc8..8661001 100644
--- a/system-sapphire.nix
+++ b/system-sapphire.nix
@@ -124,6 +124,13 @@
environment.systemPackages = with pkgs; [ git git-crypt ];
+ xdg.portal = {
+ enable = true;
+ config.common.default = [ "gtk" "gnome" ];
+ extraPortals = with pkgs; [ xdg-desktop-portal-gtk xdg-desktop-portal-gnome ];
+ };
+
+
# NOTE: I now use this as alternative to steam-run'ing every precompiled binary
# This should be much easier now, than `steam-run <binary>` every time
services.envfs.enable = true;