summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 0f4ce50..aafbfaa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -104,14 +104,25 @@
# This is for plugins that will load at startup without using packadd:
startupPlugins = {
gitPlugins = with pkgs.neovimPlugins; [ ];
- general = with pkgs.vimPlugins; [ ];
+
+ general = with pkgs.vimPlugins; {
+ always = [ lze lzextras ];
+ };
+
+ theme = with pkgs.vimPlugins; (builtins.getAttr (categories.colorscheme or "catppuccin-mocha") {
+ "catppuccin-mocha" = catppuccin-nvim;
+ });
};
# not loaded automatically at startup.
# use with packadd and an autocommand in config to achieve lazy loading
optionalPlugins = {
gitPlugins = with pkgs.neovimPlugins; [ ];
- general = with pkgs.vimPlugins; [ ];
+
+ general = with pkgs.vimPlugins; {
+ telescope = [ telescope-nvim ];
+ extra = [ which-key-nvim ];
+ };
};
# shared libraries to be added to LD_LIBRARY_PATH
@@ -180,9 +191,13 @@
# and a set of categories that you want
# (and other information to pass to lua)
categories = {
+ theme = true;
+ colorscheme = "catppuccin-mocha";
+
general = true;
gitPlugins = true;
customPlugins = true;
+
test = true;
example = {
youCan = "add more than just booleans";