aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorLibravatar Mora Unie Youer <[email protected]>2025-03-06 12:39:35 +0300
committerLibravatar Mora Unie Youer <[email protected]>2025-03-06 12:39:35 +0300
commit1f6b8994fd7c97a79ebdf285ebac1a5832917090 (patch)
tree237bd66330d6eff8e7becf10458b8dc4dffe963e /flake.nix
parentfeat(mora): install `carapace` (diff)
downloadnixos-configuration-1f6b8994fd7c97a79ebdf285ebac1a5832917090.tar.gz
nixos-configuration-1f6b8994fd7c97a79ebdf285ebac1a5832917090.tar.bz2
nixos-configuration-1f6b8994fd7c97a79ebdf285ebac1a5832917090.tar.lz
nixos-configuration-1f6b8994fd7c97a79ebdf285ebac1a5832917090.tar.xz
nixos-configuration-1f6b8994fd7c97a79ebdf285ebac1a5832917090.tar.zst
nixos-configuration-1f6b8994fd7c97a79ebdf285ebac1a5832917090.zip
fix: try to use Cachix as much as possible
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 22 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index cabce85..cfbe25f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -72,20 +72,25 @@
fjordlauncher = {
url = "github:unmojang/FjordLauncher";
+ # NOTE: re-following inputs breaks Cachix
inputs.nixpkgs.follows = "nixpkgs";
inputs.nix-filter.follows = "nix-filter";
inputs.flake-compat.follows = "flake-compat";
};
niri = {
- url = "github:YaLTeR/niri";
- inputs.nixpkgs.follows = "nixpkgs";
- inputs.nix-filter.follows = "nix-filter";
- inputs.rust-overlay.follows = ""; # NOTE: for end user is not requried
+ # NOTE: using this repo to use cachix binaries
+ url = "github:sodiboo/niri-flake";
+
+ # url = "github:YaLTeR/niri";
+ # inputs.nixpkgs.follows = "nixpkgs";
+ # inputs.nix-filter.follows = "nix-filter";
+ # inputs.rust-overlay.follows = ""; # NOTE: for end user is not requried
};
wezterm = {
url = "github:wezterm/wezterm?dir=nix";
+ # NOTE: re-following inputs breaks Cachix
inputs.nixpkgs.follows = "nixpkgs";
inputs.flake-utils.follows = "flake-utils";
inputs.rust-overlay.follows = "rust-overlay";
@@ -94,15 +99,21 @@
nixConfig = {
extra-substituters = [
- "https://nix-community.cachix.org/"
- "https://chaotic-nyx.cachix.org/"
+ # NOTE: Some of the cachix repositories do not work for some reason :^(
+ "https://nix-community.cachix.org"
+ "https://chaotic-nyx.cachix.org"
"https://unmojang.cachix.org"
+ "https://wezterm.cachix.org"
+ "https://niri.cachix.org"
];
extra-trusted-public-keys = [
+ # NOTE: Some of the cachix repositories do not work for some reason :^(
"nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
"chaotic-nyx.cachix.org-1:HfnXSw4pj95iI/n17rIDy40agHj12WfF+Gqk6SonIT8="
"unmojang.cachix.org-1:OfHnbBNduZ6Smx9oNbLFbYyvOWSoxb2uPcnXPj4EDQY="
+ "wezterm.cachix.org-1:kAbhjYUC9qvblTE+s7S+kl5XM1zVa4skO+E/1IDWdH0="
+ "niri.cachix.org-1:Wv0OmO7PsuocRKzfDoJ3mulSl7Z6oezYhGhR+3W2964="
];
};
@@ -143,10 +154,14 @@
{
nixpkgs.overlays = [
fjordlauncher.overlays.default
- niri.overlays.default
+ niri.overlays.niri
];
}
+ {
+ nix.trustedUsers = [ "root" "mora" ];
+ }
+
# System Configuration
./system-sapphire.nix